Export SQL Lite

GRAMPS: GrampsAIO64-5.1.3-2
Python: 3.6.4 (default, Jan 23 2018, 13:17:37) …
BSDDB: 6.1.0 (6, 0, 30)
sqlite: 3.21.0 (2.6.0)
OS: Windows

I have installed (overwritten the original install) the SQLLITE.ADDON. Installed into C:\Program Files\GrampsAIO64-5.1.3\gramps\plugins.

After restarting GRAMPS I get the following error message

14247: ERROR: grampsapp.py: line 157: Unhandled exception
Traceback (most recent call last):

  • File “C:\Program Files\GrampsAIO64-5.1.3\gramps\gui\viewmanager.py”, line 1361, in export_data*
  • ExportAssistant(self.dbstate, self.uistate)*
  • File “C:\Program Files\GrampsAIO64-5.1.3\gramps\gui\plug\export_exportassistant.py”, line 145, in init*
  • self.create_page_exporttypes()*
  • File “C:\Program Files\GrampsAIO64-5.1.3\gramps\gui\plug\export_exportassistant.py”, line 206, in create_page_exporttypes*
  • exporters.sort()*
    TypeError: ‘<’ not supported between instances of ‘ExportPlugin’ and ‘ExportPlugin’

Any suggestions on how to fix? It worked prior to me reinstalling it.

Don’t overwrite the builtin one manually, install the addons via Gramps builtin installer for addons see the section " Installing Addons in Gramps"


Sorry but I might have confused people. I had installed the SQLLITE.ADDON previously and it worked. I accidentally installed it a second time when installing other addons and over wrote the original install using the Sqlite.addon.tgz and that is when I get the error message when I tried to run an export.

Probably the easiest will be to delete the folder from the plugins directory. After launching Gramps, go to Addon Management in Preferences and reinstall the most recent version of the addon. You might have to uncheck the Do not ask about previously notified addons.

This is part of the core Gramps program files.

The plugin folder is (on Win10)


FYI: The appdata folder by default is hidden.

Addon Management in GRAMPS does not work as the link address must be wrong. When loading into normal browser it comes back with a 404 error. I uninstalled GRAMPS, reinstalled and loaded SQLLITE.ADDON into the directory you said and it works fine now.


I am glad you got things working. But to make things easier in the future…

You do not use a browser to check for addons in Third party addons management

The path Gramps will use for 5.1 version addons is:


But you use the Check for updated addons now button. It is working just fine. [just used it] If there are addons available to you, a list will appear that you can select from and install from the list dialog.

You can set Gramps to automatically check for addons. I have mine set to check daily when I launch Gramps for the first time each day. Most addons will automatically install with the Third Party addons management. Only a few addons need manual installation and most of these will be in a testing phase.

My system is set up with that link. When I click on it it comes back to say that there are no addons and it does this within about 1 second.

No list or anything else. Is this correct? The only addon I have in c:\user%you%\appdata\roaming\gramps\gramps51\plugins is “Forms” and “SQLLite”

This message says that all your addons are the most recent and there are no new addons.

There may be addons that you never installed. Uncheck the Do not ask about previously notified addons to see if there are any other addons available.

Hi, It is/was unticked.


1 Like

The “There are no available addons of this type” message occurs when all addons are properly installed. If you use “Help/Plugin manager” do you see the box titled “Plugin Manager - Enhanced”? That would be an indication that the enhanced plugin manager addon was installed. Within the box are listing of all the plugins. If everything is installed there should be quite a few “*Installed” items in the “Status” column. If all this is true, you may be looking in the wrong place for the addons in your file manager;
“c:\user%you%\appdata\roaming\gramps\gramps51\plugins” where the %you% is replaced with your username is the place to look. Unless you have moved your Windows profile to a different drive or location.

When I select “Help/Plugin Manager” I only get “Registered Plugins” and “Loaded Plugins”


Do I need to load " [Plugin Manager Plugin]" to get this to work?

By you displaying the standard Plugin Manager, it clearly shows that either the Enhanced Plugin Manager is not installed or by using either Manager, you have hidden the addon which based upon your questions, you did not do. If the Enhanced Plugin Manger were installed, it would automatically override the standard version.

Going on the assumption that it is not installed, it is curious that when you checked for addons, it came back that none were available. So lets try a clean new install of all addons.

While you are not running Gramps…

Unless you set a different path to you addons (GRAMPSHOME) all you plugins will be in c:\user\%you%\appdata\roaming\gramps\gramps51\plugins where the %you% is replaced with your username.

Delete (or move to a temp folder on your desktop) all the files and folders in this directory.

In c:\user\%you%\appdata\roaming\gramps\gramps51 delete the file new_addons.txt

In the same folder open the file gramps.ini and scroll down to [plugin]. The ;;hiddenplugins=[] is the default setting for hiding addons, i.e. no plugins hidden.

Now launch Gramps. Based upon your addon settings, when you launch Gramps, it will find the complete list of addons which you can select and install from the dialog list. Hopefully you will get all the addons you need/want.

Hint: I always “Select All” and install. I always have a complete list of addons installed. If there are any addons that I actually do not use, I can “Hide” them using the Plugin Manager. And if I find a need (like helping other users) I can “UnHide” them for use.


I moved the files and directories from “C:\Users%you%\AppData\Roaming\gramps\gramps51\plugins” to a backup file. There was no “new_addons.txt” file in “C:\Users%you%\AppData\Roaming\gramps\gramps51”. In fact there were no txt files in any directory under “Gramps”.

The ;; hiddenplugins=[] was already that so did not change.

Noted the following in the gramps.ini, ;;last-check-for-addon-updates=‘1970/01/01’

Restarted Gramps and the 3 addons that I backedup do not show (Naturally as they are no longer in the gramps51 directory) but also the Preferences and Check for Updates still returns the that there are none.

This is probably because your setting to Always check for updates is not date dependent.

Doing some more digging there may be another setting in the gramps.ini to make sure is reset to the default.

In [behavior]

If this does not allow a complete addons to install, maybe @prculley will have another idea.

Lines in gramps.ini show as :


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.