Development of Gramps (Mint environment configuration errors)

I’m trying to learn to modify gramps to enhance it. New to python but worked with older languages until my stroke. Lost a lot of my programming memory, lol. Using Pycharm and cloning gramps 5.1.3., I can get it to run, but Pycharm gives me a ton of error messages. With python 3.9 I can’t get glade to work as it no longer uses the gramps library files so I can’t modify any glade files. Is there a workaround for glade and python 3.9?

You didn’t mention your OS, or if you have installed the full libraries and all their associated extra programs.

For instance, if you install and build Gtk from scratch, among many other items, is the Glade editor. I’m pretty sure that is completely independent of Python 3.9. I’ve not yet done any testing with Python 3.9 myself, so I don’t know if there have any additional deprecations or other items to cause errors, but even when there are, Python is usually set up to allow deprecated features to continue working until a major version change (like Python 4.x).

On my Linux installation, the Glade editor seems to have been included along with the other Gtk items. On my Windows system (where I normally do development), the MSYS2 installation also included the Glade editor.

If this doesn’t answer your questions, please elaborate…

1 Like

using the latest mint distro. I can get the program to run now, but when I try to use glade I keep getting a The following required catalogs are unavailable: grampswidgets.

Mentioned in the README file in the same directory

This directory contains the catalog needed to use the Gramps glade files in glade.

Assuming you are in the root git directory do:

GLADE_CATALOG_SEARCH_PATH=gramps/gui/glade/catalog GLADE_MODULE_SEARCH_PATH=gramps/gui/glade/catalog/ glade

However, this does no longer work for python modules (since 3.8), so the gramps widgets are not in the catalog at this moment.

As project settings:

*format: gtkbuilder
*unique names in toplevel (so not project)

gramps/gui/glade/catalog

So looks like no solution since python 3.8 !

Also searching on the old mailing list shows the following two messages that may help?

Possibly needs to be documented somewhere on the wiki ?

Can you show the exact error warning message or maybe raise an issue on the Gramps bugtracker please?

Ah, the Gramps specific widgets issue. I admit that I often have to reset the Glade preferences, somehow the configured path in those preferences seems to override the environment variables. But if I get the env vars set correctly, and I get the Glade catalog paths in its preferences removed, I can use Glade to fully edit the files on my system. Even on my Python 3.8 installation. In fact I usually use the Glade editor from that installation as it also has the much more up to date Gtk (and Glade editor) v3.24.14.

Even without that, changes not related to the Gramps widgets can be made with the Glade editor. The XML related to the widgets will not be changed unless you directly edit one of those widgets.

And of course, you can always edit the XML .glade files by hand or with an XML friendly editor. I often do that to eliminate excessive changes made by the Glade editor when preparing a bug fix, as the automatic rearrangement of XML sections and other small changes is not really relevant to the fix.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.