Database compatibility between v4.x and v5.1.3?

After a system upgrade I moved from Gramps 4.x to 5.1.3, and no more able to open my database.
(I know I should have made a xml backup)
I have an error message saying it could be an older format of database, or some corruption.
I checked BSDDB in gramps 5.1.3 and in my db, they are both (5,3,28)
I retrieved a db backup that was for sure not corrupted, and got the same message.
Has anyone any idea for proceeding? Is there still a compatibility issue?

Running Gramps v5.1.3 on Fedora 33

Just double-checking threads due to the eMail notifications in Discourse recently self-terminating. This posting has not received a reply… Bumping.

I tried to duplicate the scenario.

Reinstalled 4.2.8 and imported example.gramps and then launched 5.1.3. When I selected the Example family tree, I got the warning that a conversion would take place But…

There was no message about a possibility that the file was corrupted.

The conversion took place and in the process, a zip backup file of the original database was created.

I was hoping someone more knowledgeable could help.

1 Like

Hello, thanks for replying,
I join two version of my database. My latest one (587f645cV1120) and an older backup that was surely not corrupted as I could go on working on it (587f645cVBXL). When trying to open these I get the error message in attachment. How could I retrieve my data?
Capture d’écran de 2021-03-16 13-11-42

I jave not found a way to join my database. Only pictures are accepeted

You can create a bug request and attach your database.

French:
Tu peux créer un rapport de bogue et y attacher ta base de données.

Did you solve your problem ?

No,
I wanted to try with an older version of gramps, but it is difficult to install it on my Fedora 33. I think I would necessary to rebuild it from sources. But fortunately I remembered I have an old laptop where gramps 4.1.3 is installed on Fedora 20 (see pic)
I tried with both version of my database and got twice an error message indicating a db corruption. I join the message and the details.

Capture d'__cran de 2021-03-20 19_03_39
It is suggested to use the ‘repair’ function, but this one is greyed and not accessible.
So still stucked :frowning:

I also tried to restart from scratch. I stil have the same error message on both db versions. But now the convert button is accessible. I tried the option and have the following criptic error message.Capture d’écran de 2021-03-20 19-13-22

Last trial, I copied the database in a directory ~/test, and tried the Oracle db utilities as suggested in the wiki Recover corrupted family tree - Gramps.
I got the following result


I must say I do not understand a word of it. First why is it trying to repair my original gramps db and not the copy in my test directory. It looks like there are conf. files somewhere…

If you save your test directory, how big is it?
Do you remember the number of people in your database?
perhaps you could send it to me : serge dot noiraud arobas free dot fr

I send you the two gramps files (5.1.3) for your database.

It is working, what was the issue?

“Unsupported pickle protocol” usually means that the db somehow got updated when a newer version of Python was installed in your machine. When trying to open the db on a machine with the older version of Python installed, Python did not know how to deal with the changes. Issues like this are why we try to get users to make backups in XML, and use those to move to other machines. The db data itself, is not quite as forward/backward compatible as we would like.

1 Like

Hopefully user SNoiraud could restore my db from the db files I provided.Thanks to him
I’m curious of where the problem was laying and how he did.
Anyway the problem is solved for me and I got the point regarding XML backups

But the moral of the saga… Backup… Backup… BACKUP!

I only click on “I have made a backup, please upgrade my Family Tree”

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.