Ver AIO64-5.1.3-2 64 Keeps Asking to Update New Gramps View

Just installed the latest Gramps 64bit version. Every time I start Gramps the Available Gramps Updates for Addons box pops up suggesting that I install the New: Gramps View addon, one for LifeLine Ancestor and one for LifeLine Descendants. I select all and install and the system says the installation was completed OK. So, I quit out of Gramps and then restart it and the same message comes up repeatedly. Not exactly a show stopper, but…

GRAMPS: GrampsAIO64-5.1.3-2
Python: 3.6.4 (default, Jan 23 2018, 13:17:37) …
BSDDB: 6.1.0 (6, 0, 30)
sqlite: 3.21.0 (2.6.0)
OS: Windows 10

There is an INI file in your plugins directory.


Delete this file.

Warning: Windows makes the appdata folder hidden by default.

Now when you are prompted to install you should get a dialog to install some additional files. The ini file was preventing the prompt for the additional files so the views never fully installed.

The two views it creates under Charts are pretty neat.

1 Like

Thanks! Works great.

I’ve updated the PlaceCoordinate Gramplet so that it will stop doing this if the user installs the fixed AIO (or updates other OS parts so it can start working again). Still have to do the same for the LifeLine Charts…

1 Like

Thanks for the quick response.

I have a very similar situation only on Linux. I am offered the two new Gramps Views: Life Line Ancestror Chart 1.3.13 and Life Line Descendant Chart 1.3.13 I install them both supposedly sucessfully when I restart gramps they do not show up in the toolbar of the Chart View.

I tried deleting the ini file mentioned above from /home/cindy/.gramps/gramps51/plugins/lifelinechartview_warn.ini
but it just gets recreated but the plugin is not installed.

System Information:

Gramps version: 5.1.3
Python version: 3.8.2 (default, Jul 16 2020, 14:00:26) [GCC 9.3.0]
BSDDB version: 6.2.7 (5, 3, 28)
sqlite version: 3.31.1 (2.6.0)
OS: Linux
Distribution: 5.4.0-45-generic

GTK version : 3.24.20
gobject version: 3.36.0
cairo version : (1, 16, 2)

I just had a new lifelinechartview (1.3.13) available in this morning’s update. I checked the previous (1.3.12) and found that it did not load. Installed 13 and after restarting Gramps the two views did not load.

I deleted the lifelinechartview (13) folder and the lifelinechartview_warn.ini. Restarted Gramps then checked for new addons. Installed lifelinechartview (13) again and was asked to install the two needed modules which I did. Restarted Gramps and the two views were NOT installed. Deleted lifelinechartview_warn.ini and tried to install through the enhanced plugin manager where the two views were listed as available. and again after restarting Gramps, the views did not install.

Found an older version (1.3.11) in my backups and it loaded the two views. This is the version I got working by deleting the ini file as I describe above.

@prculley guess there was one step forward but two steps back with the latest updates.

Note: I am on Windows running 5.1.3-2. Not sure what special consideration is needed on a Linux install.

Version: 1.3.14 just installed on a Windows 10 box. The install from Preferences popped a 2nd dialog that the module did not install but offered a chance to try again.

That worked. Now Life Line Ancestor Chart and Life Line Descendant Chart appear in the view and work. (Thanks @prculley !)

So, the ‘M’ button in the upper left doesn’t have a rollover hint. And it isn’t in the docs. Anyone know what it is for?

1 Like

1.3.14 correctly installs (Win10 5.1.3-2) and I really like the new scrolling.

Looking at the code, the M toggles a Translation.

1 Like

Christian Schulze just updated his documentation.

The ‘M’ button toggles the mousing behavior in the view. It is like a ctrl key for Mouse drag and Scroll-Wheel actions. (Something like a caps lock is a toggle for the Shift key.) So, it is a ‘ctrl lock’

The ‘M’ button impact for:

  • ‘Left mouse button drags’: toggles the ‘drag the zoom frame’ on & off
  • Scroll-wheel: toggles between scrolling & zooming
  • - & +: toggles between zoom out/in & no action

Note: numeric keypad - & + are not recognized.

Thanks Mr. Schulze! And thanks for sharing this tool!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.