SuperTool giving error when selecting "filtered objects"

I recently started experimenting with SuperTool. I can get table output by selecting “All objects” or “Selected objects”. However when I select “Filtered objects” I always get “gramps.gen.errors.HandleError: Handle is None”. I even tried removing all of the statements and I still get this error. Am I using the tool wrong or is there a bug?

Note that I’m using a Custom Filter in the Filter gramplet.

1 Like

Did you reference a custom filter in the “Filters:” section of the SuperTool dialog as described in the section: “using predefined custom filters”?

(It doesn’t matter which filter is set in the Category view mode with the “Filter” gramplet.)

Yes, I believe this is a bug in SuperTool: the “filtered” option does not work in the grouped people view! I will try to figure out how to fix this.

Did you use the grouped people view? Can you try the ungrouped view?

I mean the “Custom Filter” in the filter gramplet. See the image below and note the Custom filter dropdown.

I normally have the grouped view on. I switched to the ungrouped view and indeed it works.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.