Ordering column by estimated dates

When clicking on the “Date” column of any window to order events/media/citation, etc chronologically, it seems that Gramps is not able to order properly the items using “estimate dates”:

Any hint?

As I understanding the workings, those are not date entries, the are straight text, so can’t be sorted as a date.

Thanks, I see Gramps treatS “Estimated”, “Calculated”, “About”, and other Quality / Type modifiers dates as simple text, not as aproximate dates, which is what they actually are.


It would be nice if Gramps was able to figure out that “Estimated 1940” is an earlier date than “Estimated 1980.”

Instead of using “Estimated”, if you leave it as “Regular” and enter “about 1988” then it should sort correctly.

This looks like a bug to me.

1 Like

Unfortunately that doesn’t work either. The described behaviour also applies to “About” dates, at lease on my system (W10)

Thanks, I’ve reported it in the bugtracker.

OK, I think I’ve figured out what the problem is. My OS (Windows 10) is in Spanish, but when I installed Gramps I didn’t installed any Gramps translation. I NEVER use translated software for several reasons, the main one is that it makes troubleshooting WAY more difficult, since most of the help pages, tutorials and software forums are in English.

Now, the problem is that even if I never asked for that, Gramps insist on installing its spanish version (with english interface, since it can’t find the spanish files) simply because my OS is in spanish, and therefore expects all information entered by the user to be in Spanish.

That’s why when I entered “About 1930” or “Estimated 1930” through the dates editor, the program didn’t recognize this info as correct dates, and treated it as simple text, being unable to sort these items correctly in the columns (as described above) or to do any other calculation with this information. Changing “About” for “Hacia” and “Estimated” for “Estimado” “fixes” this issue.

Since it seems there’s no way to change language within the program, I reinstalled Gramps with spanish translation and all seemed to work as expected.

The problem is that, by the reasons given above, I really don’t want to use the spanish version, so I try to install the native english version by changing my OS language to english, uninstalled Gramps and installed it again, without translations. Unfortunately that didn’t solve the problem, Gramps still expects user input in spanish EVEN when I never asked for it and even when my OS is in english.

I guess the uninstall wasn’t complete and there’s some configuration somewhere telling Gramps that the user language is spanish.

Any help?

1 Like

OK, after reading this thread, I think I’ve found the solution:


Not intuitve at all, but it seems to work, even when the date validator still recognizes the old dates as text and now I have to change all of them manually from “Estimated” dates (recognized as text) to “Estimated” dates (recognized as dates) by clicking on each event and just pressing OK. :roll_eyes:

I wish there was an easier and user friendly option to change language within he program.

You can force Gramps to run in another language.

I am native English (US) but have installed the Dutch language files. My main usage is in English but I created another shortcut file in the windows program list/folders for when I want Dutch.

The shortcut’s Target line is:

%comspec% /c set LANG=nl_BE.UTF-8 && start grampsw.exe"

Obviously, you would use en_GB

1 Like

Yes, that’s exactly what I did (see my previous post). Kind of counterintuitive, but it works.

Any new user installing gramps (English version) in a non English OS is going to experience the same problem, I guess. And figuring out what the problem is, is not easy at all, specially for new users (like me). It’s really confusing because the program (as described above) appears to be in English, but it’s actually not, and there’s no way to realise this until you start to notice that certain areas of the program (like date validator, column sorting and date calculations) are behaving unexpectedly / incorrectly.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.