No backup when leaving

Why, when an automatic backup has occurred and no data has changed, do a save again when exiting Gramps? Why not leave directly?

I too have noticed this happening. I open Gramps and navigate to a person to find an answer for a family gathering. “… when did aunt mary die? etc.” I will have often opened and closed several edit windows and then closing them after making no edits.

While minorly irksome, I see it as an assurance of having the backup. And it does take some time to make a backup on my Master Tree. Its current compressed .gramps size is 34.8MB.

There were a series of enhancement requests filed for the Backup feature.

Most have Pull Requests. I think that these PRs have all been merged into the 5.2 master. — but it is worth double-checking.

These include:

  • 0012563 “Abandon changes & Quit” performs unnecessary “Backup on exit”
  • 0011916 don’t auto-backup if nothing has changed (This was for timer controlled autobackup. Have not checked if it affects backup on exit)
  • 0011813 Add extended interval choices {12hrs & 24hrs} to automated backup
  • 0010953 delay auto backup triggering when coming out of OS hibernate

Not yet implemented:

  • 0012311 Restoring a backup fails with “cannot find” error
  • 0011817 Backup option: Add Note selection for ReadMe.txt insertion
  • 0011558 Exit is not abortable when backup upon exit fails
  • 0011061 [Autobackup](Automatic backup) Add option(s) to control maximum number of file backups or maximum disk space allocation used
  • 0010327 [MS-Windows] Default backup path name (to Gramps User Directory)

Just curious, and a bit lazy. Do we have a report about Gramps not making a backup when you switch trees? Switching means leaving tree A in favor of tree B, so it makes sense to create a backup then too.

1 Like

The reports linked above were all the outstanding ‘backup’ that were found with about a half-dozen searches.

Thanks for looking. I just created a report for this:

1 Like

added “backup” tag and set as related to the bug on “abandon changes”

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.