Is there anyone else working with LMDE 6 or Debian Bookworm?

After upgrading from LMDE 5 to 6, I noticed that Gramps 5.1.5 as supplied in the official repo can’t find GeocodeGlib, even when I install it via Synaptic.

Closer inspection revealed, that in LMDE 6, and Debian 12, the only available package is gir1.2-geocodelib-2.0, and earlier versions, and ubuntu based Mint 21.2, have version 1.0.

This means, that for me, there is a simple solution, which is hacking the Place Coordinate Gramplet to retrieve version 2.0, and that works.

Should I file a report for this?

LMDE is a bit behind some other Linux distributions. It is a cross we have to bear or switch to Linux Mint.

How do you mean behind? LMDE 6 is based on Debian 12, not 11, so it’s ahead of the regular Mint.

On a quick search I found lmde 6 but no information about Linux Kernal or Debian version. So I jumped to a conclusion unwarranted. Having said that LMDE has never claimed to be a leading edge distro.

OK, I understand. And in most cases it is true, since there are more releases for the regular mint than for LMDE. This version however is really ahead, and it gives me a few challenges, that Debian Bookwork users may also see.

But until now, it looks like I’m the only one with LMDE 6 here.

There are only about 900 registered users on this site.

And of those about 700 are logged in (or following threads) daily. Plus about the same anonymous visitors.

With a pool as small as 1,400 users, there’s a good chance that you won’t find a match.

And, yes. Filing a upward compatibility bug report for the Place Coordinates would be reasonable. (and possibly checking the Prerequisites gramplet would be good.)

I filed a report, but didn’t check the prerequisites gramplet, because I’m still running 5.1.5. The prerequisites gramplet is new in 5.2.

There is a new 5.2 update for Prerequisite Checker. But I think that the Gramplet version of the command line -v option was developed for the 5.0 version.

I just don’t know if it can list which functionalities need a particular library … so we can test if the others fail to recognize that newer version too.

Thanks for reminding me. I never add it to my dashboard, because I rely on the error messages that I get when installing things, or the ones that keep popping up on start, or are displayed in terminal. The Gramplet is too much for me, partly because it spends too many words on things that are OK.

Anyway, in this case, it does show an error:

  • geocodeglib niet gevonden (Vereist versie 1.0 of hoger geïnstalleerd.)

This translates to not found, and version 1.0 or higher needed, and Synaptic and the actual hacked Gramplet proove that version 2.0 is installed.

In other words, the prerequisites checker needs an update too.

I just noticed that you mentioned the geocodelib package in another thread:

Can you tell me what version of that is distributed with Fedora? I expect Red Hat to be state of the art, and if Fedora follows that, I expect it to move fast too.

Users may also have similar problems with other fast moving Linuxes, especially the ones with rolling releases:

But OTOH, these distros may also be the first to adopt Gramps 5.2 when it’s ready.

I have updated the Place Coordinate addons in the v5.2 repository to work with either GeocodeGlib 1.0 or 2.0.

1 Like

We have another big problem:

$ apt-cache depends gir1.2-osmgpsmap-1.0
Dépend: libosmgpsmap-1.0-1
Dépend: gir1.2-glib-2.0
Dépend: gir1.2-gtk-3.0

$ apt-cache depends libosmgpsmap-1.0
Dépend: libc6
Dépend: libcairo2
Dépend: libgdk-pixbuf-2.0-0
Dépend: libglib2.0-0
Dépend: libgtk-3-0
Dépend: libsoup2.4-1
Est en conflit avec: <libosmgpsmap-1.0-0>
Remplace: <libosmgpsmap-1.0-0>

$ apt-cache depends gir1.2-geocodeglib-2.0
Dépend: gir1.2-glib-2.0
Dépend: gir1.2-json-1.0
Dépend: gir1.2-soup-3.0
Dépend: libgeocode-glib-2-0

As you can see:
libosmgpsmap depends on libsoup 2.4-1
and Geocodeglib depends on libsoup 3.0

And if we want to add a place from a geography view (Right mouse button then “Add place” or “Link place”
we get the following:
( libsoup-ERROR **: 17:43:45.402: libsoup2 symbols detected. Using libsoup2 and libsoup3 in the same process is not supported.
then gramps stop without crash

We need to make a bug report for debian.

1 Like

I notice that osm-gps-map has already been ported to libsoup3 in PR #99.

However, the project is no longer maintained, and the last release was in Feb 2021.

Perhaps we should contact the owner, and perhaps the two users who have open pull requests, to get an update on the situation. There is an attempt at updating the code for Gtk4, but this will also impact us before too long.

Are you a Debian user yourself? I never really used it, other than for testing, and I had so many problems with LMDE 6, that I decided to give up on that, and follow the mainstream of Linux Mint, which is based on ubuntu.

No, I’m an ubuntu user. I used to install and develop on Debian machines a few years ago.

I made a bug report for debian:


This isn’t actually a Debian issue. Someone needs to make a new release (1.2.1) of osm-gps-map.

The last release was made by Hubert Kowalski (johnny-bit) in Feb 2021. He is probably the best person to contact. It doesn’t look like the owner, John Stowers, has been active for some time.

The documentation page gives limited contact details, and the mailing list is almost inactive.

I have opened a new issue #102.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.