413 with apache reverse proxy in front of docker when uploading media because of uBlock Origin Adblocker

Hello,

I am using a apache2 reverse proxy in front of a grampsweb docker. The grampsweb container is set up with the standard docker compose file. Uploading media to the container without the reverse proxy does not lead to the 413 error (there it does not work as well but that is a 2nd issue and I will open another thread for it).

I tried to find settings in the reverse proxy to change this but I did not have any success.

Just when I am writing this I had the idea to stop the adblocker uBlock Origin 1.53.0 I use in firefox (chrome did not work either but I think I have an adblocker there as well). That actually solved the issue and I can upload not only the small 40kB zip but also 2 and 7MB. I will later try my complete media archive.

Should someone else encounter this issue it might be helpful.

Thanks, interesting.

Upload file size limits are often tricky, e.g. in our recommended Nginx config we need to manually increase it because the Nginx default is too restrictive, see https://github.com/gramps-project/web/blob/main/examples/docker-compose-letsencrypt/nginx_proxy.conf.

But that an ad blocker can cause this is new.

By the way, if you have a working, minimal Apache reverse proxy setup, feel free to add this to the documentation at GitHub - gramps-project/web: Documentation for Gramps Web.

Thank you for your reply.
I am willing to share the apache reverse proxy settings when I have tested the whole thing for a bit, and got everything working. I.e. I still have another issue with media upload I have not yet been able to fix and will mention next week or so when I have a bit of time.

1 Like