Import very old database

Many years ago I’ve started using (for a short time) gramps to build my family tree. Now I’d like to return to my work. I have a grdb file (file date is yesr 2012) but current version is not recognizing these file and ask to convert in to xml version with gramps 3.0.x. I’ve tried to open it with gramps_3.0.4-1_Ubuntu810.deb version (new family tree and then import) but these version fails to import (I can see messages "Found import plugin for GRAMPS 2.x database /tmp/some_tmp_file and “/tm/some_tmp_file could not be opened”). Any ideas how to recover my data and use it nowadays?

The following page mentions grdb file in the example:

With that information try one of the Linux Genealogy CD’s (in a Virtual Machine) which has various versions of Gramps from 2.0.8 to 3.2.5.

Another option is to raise a private issue requesting one of the developers convert the file eg: see other peoples request for the same thing :

Thanks for reply. I’ve tried “Linux Genealogy CD’s” way but:

  1. 6.1 version is not recognizing my databaes
  2. 4.0 and 3.0 iso seems to be broken: wan’t boot under proxmox (not tried under Virtual box) and Ubuntu refuses to mount it claiming that ISO is broken…

I’ve downloaded these files twice and it have (two times the same) md5sum different that in md5sum files.

I’ve managed to recover my data using 2.0 desktop but still there is an issue with 3 and 4 versions (ISO is broken).

1 Like

Maybe this is a cautionary tale.

That even though we are currently working on our research entering new and corrected information into our databases it may be advisable to regularly add a total database export to a GEDCOM file to our regular database maintenance routine. This would not replace regular backups to .gramps xml as a primary means of securing our information.

But… nothing is guaranteed in life and currently (until Gramps’ XML becomes the standard) GEDCOM is the surest way that 10 years from now another genealogy program will be able to revive our research.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.