Import/convert old database


I tried to import a very old database before 2016. It seems possible with version 3.0x according to the message, but that version cannot be installed due to compatibility with my current Linux Mint version.

Can anybody help me with this??

There are about seven databases I need to import and get back from ancient times…

thanks in advance,


1 Like

Hallo Willem,

Dit zou niet zo’n probleem mogen zijn, want ik ben zelf vrij recent overgestapt van 3.4.9 naar 5.1.x, en dat lukte door een backup in .gramps-formaat te importeren.

Als je wilt, kun je ook een privebericht aan me schrijven, zodat ik je mijn emailadres kan geven, en ik eventueel naar je bestand kan kijken. Versie 3.4.9 is ook nog beschikbaar voor Windows, als je dat nog ergens kan draaien. En als die dan nog 3.0-formaat of zo kan lezen, kan je in twee stappen migreren.

Er is zelfs een kans dat die oude 3.4.9 voor Windows ook goed onder Wine draait …

groeten uit Driebergen,


I think your version is definitely older than gramps 3.0 as you can’t import it.
depending on the size of your database, I can solve this problem.
My email: serge dot noiraud at free dot fr


Note that the final output of recovering a database file is normally a.gramps or .gpkg file. Then you can import that into a new, blank tree.

It is important to note that the database only has filename & path pointers (some may be relative, some may be absolute, some may be internet URLs)… the database does NOT store the actual media objects.

So your recovery process must include restoring the recovered file to the original machine. Then you can make a backup INCLUDING media.

This backup file WILL include the media objects (but NOT the Internet URL media) for transport to a different machine. (You could used the DownloadMedia tool addon to harvest copies of the Internet URL media to local files.)

If some of the media objects use Absolute filepaths instead of the Relative paths, there may be a littering of additional directories. Some file management housekeeping work might be needed.

After re-organizing the file, use the Media Verify tool addon to resolve the new locations.

Our wiki suggests that every version can read all previous schema versions, which is obviously not true:

Any idea which schema versions are really supported by the Gramps versions listed here? For import I mean, or conversion, when found inside the grampsdb folder.

The latest version of Gramps should be able to read schema version 14 and later.

So, when there’s a recommendation to use 3.0, the detected schema is 13 or earlier. Is there something that Willem can do, to figure this out, other then let one of us have a look?

Is there a reference that would allow updating that page (or the table for XML schemas) to indicate which Gramps versions can import which schema databases?

Use Gramps 3.0 to load schema version 13. Use any modern version to load schema version 14 or above.

I don’t know how to identify the schema version for very old databases.

Do you think 3.4.9 could load version 13? If so, a USBthumbdive with PortableApps 3.4.9 Gramps plus a current version could make a viable recovery platform.

Or for Linux, the Live CD has 3.2.5 and a new install.

It can load schema version 13 if it is in the newer database format. Version 3.0 contains the GrampsBSDDB class which can load the older 2.2.x GRDB format.

I’ve only had a very quick look at the old code, but it seems that the metadata table was renamed from “meta.db” to “meta_data.db” in the upgrade to the newer format. In both cases the table contains a key called “version” which holds the schema version.

1 Like

It’s been a hard days… etcetera

I tried a lot of things…

The live-CD does not work on modern PC’s, it stop during boot (why? …)

The 3.0 version needs very old Linux versions. I tried it and it turned out that the repositories are unavailable for Mint (Ubuntu, Debian, straight forward and via Wine) and Windows.

The windows version and the Linux version both need very old python releases which are no longer available.

Version 3.4.9 can be installed but gives an error and tells me I need to use 3.0…

So may hours of work in the old days seem to be lost.
In these old days I used to produce a genealogy program myself, called LaFam. I always secured the import of older database versions, even over a period of ten years and more, that’s normal I believe. Trough automatic recognition and import or conversion programs. Why not so for Gramps I wonder…

Can anybody help me with a hint or reason why the live-CD might not work?

Many thanks an a nice (though stormy) day…



Een privé bericht…

Helaas kan ik niet vinden hoe dat te doen…


I have the live CD working in VirtualBox, running Linux in Linux, but I’m not sure whether version 3.2.5 is old enough to read your tree(s). There are older live CD’s too, but when I run one of them in VB, I have a mouse scaling problem, so it’s pretty hard to use.

I hope that someone can tell us which CD is the best, and I may try the older one on my laptop, which is also quite old.

I sent you a private message too, and am looking forward to see one database folder or the whole grampsdb folder with everything inside it in my mail, addressed to my username here, followed by gmail dot com.

And if you dare to drive in this ‘storm’, you can also pay a visit to Driebergen.

I send you your two databases converted with gramps 2.2

If you are on Windows 10-11, install hyper-v, then install Windows XP as client and then install Gramps v. 3.0 on the XP client…

Or if you can find one, install an old Linux distribution.

Alliteratively you might be able to use any other virtual machine software to install an older Linux distribution on a virtual client.

I think that is your best bet to get Gramps 3.0 installed.
Then when you have got your database saved in a newer version of the backup, you can install/upgrade to the latest 3.x version, export a new backup, upgrade to Gramps v 4.x if needed to export to a backup/export format that can be opened in version 5.x

Here is an article on how: How to Install Windows XP in Hyper-V | SYSNETTECH Solutions

or send the file to SNoiraud as he suggested to see if he can help you.

EDIT: I forgot that you might as well be able to run your liveCD from within a virtual machine with Windows XP installed, you just need to enable the CD drive for the client image.

Thanks to all of you for helping solve this issue.
Special thanks to Serge, he rescued the files with an ancient version of Gramps for me…

The thread can be closed.

Hello Serge,

Still curious: Is this something that we can do with one of the live CD’s, and if so, which?




Serge has successfully recovered data for quite a number of users. And he has kindly offered volunteered again. His offer was your best option.

However, your message triggered our desire to capture the institutional knowledge about this workflow. So that DIY is more possible.

My assumption was that the Live CD was a bootable Ubunto basic environment… so it could see local storage devices (with your problematic database) but take OS compatibility out of the equation. [The LiveCD only support x86 architecture.]

It is important that we learn from your experience that this may no longer be what is happening

My own experience suggests that the most recent live CD, i.e. version 6.1 with Gramps 3.2.5 is not good enough, which is exactly what Nick wrote above. And version 4 gave problems here, both in VirtualBox and on my laptop.

We have a full list of live CD’s here:

1 Like