Cannot open Database

I am using Gramps 3.3.1-1 and 32bit Win10 and cannot open my database anymore.

Can anyone help me with this infos, please:

1343492: ERROR: dbloader.py: line 316: dbloader: read_file: DbEnvironmentError detected

Error Details:

2702: WARNING: spell.py: line 59: pyenchant muss installiert sein
2702: WARNING: spell.py: line 67: Rechtschreibprüfung ist nicht installiert
25168: ERROR: dbloader.py: line 316: dbloader: read_file: DbEnvironmentError detected1343492: ERROR: dbloader.py: line 316: dbloader: read_file: DbEnvironmentError detected

System Information:

Python version: 2.6.6 (r266:84297, Aug 24 2010, 18:46:32) [MSC v.1500 32 bit (Intel)]
BSDDB version: 4.7.3 (4, 7, 25)
Gramps version: 3.3.1-1
LANG: de_DE.UTF-8
OS: win32
Distribution:

GTK version : (2, 16, 6)
pygtk version : (2, 16, 0)
gobject version: (2, 26, 0)
cairo version : (1, 4, 12)

Anton, the first thing to do is make a copy of you database directory.
The easy way is to use Windows to save a copy (^c ^v).
The database directory is probably at “C:\Users\anton\AppData\Roaming\gramps\grampsdb”

This copy is in case something goes wrong trying to recover your database.

Did you ever make a Gramps backup?

The 3.3.1 version of Gramps was released in 2011, do you still have install files?

I’ll start with the obvious… that version of Gramps is 9 years old! (3.3.1 was released 1 Oct 2011) Any suggestion should be attempted with an abundance of caution, with the expectation that it could not have been pre-validated on a similar system setup.

:stop_sign:Caution: Read the WHOLE paragraph before attempting.

You can check the database folder path for a version 3.3 of Gramps in the Preferences. However, do NOT try to open any Tree before copying the folder. :no_entry_sign: We are not aware of whether your Preferences were set so Gramps tries to re-open the last used Tree database upon restart. :warning:That would be BAD. Each time a database file is opened, the database engine automatically tries to update it. So successive failures to open a database file can add layers of corruption. (That’s just the nature of datbases. And it is why Gramps now has automatic backup.)

It would be better to look at the gramps.ini file with a text editor instead. But, if you knew how to do that, you probably wouldn’t have asked this question.

See the 3.3 manual page on Database Preferences

My used old Version ist the portable one. So I still have these “install” files.

And unfortunately I have no backup. I did not use gramps for many years and now I have the problem that I can’t go on.

And I didn’t want to update with a current problem because I’m not sure it might make it insoluble.

I checked the paths inside the preferences and also inside the gramps.ini.
The path ist correct.

Now, I will try to install an up-to-date version and get a little more effect with a database copy.

Great! You have portable installation so you can copy the whole thing before trying anything potentially destructive.

The current versions of the gramps.ini have a backup or archive path. If your 3.3.x version has the same, check that path for a .gramps file & its timestamp. If it is reasonably close to the .db file timestamps, import the backup into a new Tree.

Importing those XML (or 7zip compressed XML) files will always be less work than database recovery.

Also, since you’re already in the gramps.ini file in that freshly made backup copy of the portable installation… (With the original portable media detached, of course.)

Disable the preference to ‘automatically load last database’ .

I solved the problem.
Looking into the Log-file revealed a path from the portable media with drive G:
After restoring my lokal path as a virtual G: the database opened without problems.

Thank you all for your advice!

In next step I will update to newest Gramps using XML Export/Import

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.