Available Gramps Updates for Addons problen

OS Mint 20 64bit; Gramps 5.1.1 (recent upgrade).

Regarding Available Gramps Updates for Add-ons,
When flagging alI, I get the the message “Installation Errors”

  • PostgreSQL (1.0.12)
  • Graph View (1.0.128)
  • Network Chart (0.0.25)

For all Addon install preference options:- including

  • Updated add-ons only
  • New add-ons only and
  • New and Updated add-ons

Trevor

There are add-ons that have prerequisites not included with the standard Gramps installs. Their prerequisites must be manually installed before the Add-on registration can be successful.

The Prerequisites Checker add-on is a useful Dashboard gramplet to explore.

Some (like PyGoocanvas for Graph View and pygraphviz for Network Chart) are generally useful but add quite a bit of overhead. So you need to be aware that you are adding complexity to your Gramps installation.

Refer to this thread for lead on resolving those particular error messages on a Linux (Ubuntu) system:

Some (like PostgreSQL) are add-ons that are used rarely and for specific objectives. Don’t worry about those add-ons unless you identify a need to install those particular tools.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.